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บทคัดย่อ 
               บทความวิชาการนี้มีวัตถุประสงค์เพื่อนำเสนอการวิเคราะห์ข้อมูลในการวิจัยเพื่อพัฒนาการเรียนรู้ โดยใช้โปรแกรม 
PSPP ซึ่งเป็นโปรแกรมสำเร็จรูปทางสถิติที่ไม่มีค่าใช้จ่าย เหมาะสำหรับการวิเคราะห์ข้อมูลในการวิจัยเพื่อพัฒนาการเรียนรู้
เพื่อให้ได้ผลการวิเคราะห์ข้อมูลที่มีความถูกต้องและแม่นยำ สามารถลดความผิดพลาดในการสูตรในการคำนวณค่าสถิติต่าง ๆ 
รวมทั้งประหยัดเวลา และนำไปสู่การลดความคลาดเคลื่อนที่อาจจะเกิดขึ้นในงานวิจัยได้อย่างมีประสิทธิภาพ ประกอบด้วย             
2 ประเด็นหลักที่เกี่ยวข้อง คือ การพิจารณาในการเลือกใช้สถิติที่เหมาะสมในการวิจัยเพื่อพัฒนาการเรียนรู้ ได้แก่ ระดับการวัด
ของตัวแปร และการพิจารณาเลือกใช้สถิติที่เหมาะสมในการวิจัยเพื่อพัฒนาการเรียนรู้ และการวิเคราะห์ข้อมูลในการวิจัยเพื่อ
พัฒนาการเรียนรู้ โดยใช้โปรแกรม PSPP ได้แก่ การวิเคราะห์ข้อมูลโดยใช้สถิติเชิงบรรยาย สถิติเชิงปริมาณ การวิเคราะห์
เปรียบเทียบความแตกต่างของค่าเฉลี่ย และการวิเคราะห์ความเที่ยงของเครื่องมือการวิจัย    
 

คำสำคัญ : การวิเคราะห์ข้อมูล, การวิจัยเพื่อพัฒนาการเรียนรู้, โปรแกรม PSPP  
 

Abstract 
  The objective of this academic paper aims to present a method for data analyzing in 
research for learning development. By using PSPP program, it is a free statistical package program. 
This program is suitable for data analysis in research to improve learning. The program saves time 
and reduce the discrepancies which may occur in research including 2 main points; the appropriate 
choosing statistics program in research to improve learning, namely the level of measurement of 
variables, and the methods for analyzing data in learning development throughout PSPP program. 
This article also analyzes data by using descriptive statistics, comparing with the mean difference, 
and analyzing the reliability of research instruments to obtain accurate data analysis. 
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1. บทนำ 
               การวิจัยเป็นเครื่องมือสำคัญในการแก้ปัญหาและการพัฒนาองค์ความรู้โดยการวิจัยเป็นกระบวนการแสวงหา
ความรู้อย่างเป็นระบบความเป็นเหตุเป็นผลเพื่อที่จะค้นพบข้อความจริงและความสัมพันธ์ของสิ่งต่าง ๆ และได้มาซึ่งความรู้หรือ
ข้อค้นพบใหม่ที่เช่ือถือได้โดยใช้กระบวนการทางวิทยาศาสตร์ สำหรับการออกแบบการวิเคราะห์ข้อมูล (analysis design) นั้น
เป็นขั้นตอนสำคัญของการดำเนินการวิจัยในการกำหนดแนวทางเพื่อตอบปัญหาการวิจัยให้สอดคล้องกับวัตถุประสงค์ และ
สมมติฐานการวิจัยที่กำหนดไว้ได้อย่างถูกต้องและครบถ้วน  
       ปัจจุบันการวิเคราะห์ข้อมูลเพื่อตอบโจทย์การวิจัยเพื่อพัฒนาการเรียนรู้นั้นได้มีการนำเทคโนโลยีคอมพิวเตอร์เข้ามา
มีส่วนสำคัญในการประมวลผล มีการพัฒนาโปรแกรมสำเร็จรูปทางสถิติที่หลากหลายเพื่อให้ได้ผลการวิเคราะห์ข้อมูลที่มี              
ความถูกต้อง แม่นยำ ประหยัดเวลา และลดความคลาดเคลื่อนที่อาจจะเกิดขึ้นในงานวิจัยนำไปสู่ความน่าเช่ือถือของผลการวิจัย 
โปรแกรมที่นิยมใช้ในการวิเคราะห์ข้อมูลนั้นก็คือ โปรแกรม SPSS เนื่องจากเป็นโปรแกรมบนระบบปฏิบัติการวินโดว์ สามารถ
วิเคราะห์ได้ง่ายและสะดวก แต่เนื่องจากโปรแกรม SPSS เป็นโปรแกรมที่มีลิขสิทธิ์ ผู้ใช้ต้องเสียค่าใช้จ่ายในการใช้งานโปรแกรม  
ปัจจุบันมีผู้พัฒนาโปรแกรมสำเร็จรูปทางสถิติ PSPP ซึ่งเป็นโปรแกรมที่ไม่มีค่าใช้จ่าย มีรูปแบบโปรแกรมแบบอนุญาตให้ใช้เสรี 
(freeware software) มีลิขสิทธิ์แบบเปิด (Open Source) สามารถนำไปใช้วิเคราะห์ข้อมูลโดยไม่เสียค่าใช้จ่ายมีการออกแบบ
ให้ใช้ได้ง่ายคล้ายกับโปรแกรม SPSS นอกจากนี้ในการวิเคราะห์ข้อมูลเพื่อตรวจสอบคุณภาพของเครื่องมือที่ใช้ในการวิจัยที่มี
ลักษณะเป็นแบบทดสอบแบบปรนัยมีการให้คะแนน 0,1 (เช่น แบบทดสอบแบบปรนัยหลายตัวเลือก เป็นต้น) นั้นสามารถ
วิเคราะห์โดยใช้โปรแกรมอีกหลายโปรแกรม เช่น โปรแกรม Tap และโปรแกรม EVANA ซึ่งเป็นโปรแกรมแบบอนุญาตให้ใช้เสรี
ไม่เสียค่าใช้จ่าย โดยในบทความนี้จะกล่าวถึงเฉพาะการวิเคราะห์ข้อมูลโดยใช้โปรแกรม PSPP ในส่วนที่เกี่ยวข้องกับการ
วิเคราะห์ข้อมูลเพื่อตอบโจทย์ของการวิจัยเพื่อพัฒนาการเรียนรู้ ซึ่งได้แก่ การวิเคราะห์สถิติเชิงบรรยาย/สถิติเชิงปริมาณ ได้แก่ 
ความถี่และค่าร้อยละ ค่าเฉลี่ยและค่าส่วนเบี่ยงเบนมาตรฐาน  การวิเคราะห์เปรียบเทียบค่าเฉลี่ย และการวิเคราะห์ค่าความ
เที่ยงของเครื่องมือการวิจัย  
 บทความนี้มีวัตถุประสงค์ในการนำเสนอวิธีการวิเคราะห์ข้อมูลโดยใช้โปรแกรม PSPP สำหรับการวิจัยเพื่อพัฒนา 
การเรียนรู้ ประกอบด้วย 1) การพิจารณาในการเลือกใช้สถิติที่เหมาะสมในการวิจัยเพื่อพัฒนาการเรียนรู้ ซึ่งได้แก่ ระดับการวัด
ของตัวแปร และการพิจารณาเลือกใช้สถิติที่เหมาะสมในการวิจัยเพื่อพัฒนาการเรียนรู้ และ 2) การวิเคราะห์ข้อมูลในการวิจัย
เพื่อพัฒนาการเรียนรู้ โดยใช้โปรแกรม PSPP ได้แก่ การวิเคราะห์ข้อมูลโดยใช้สถิติเชิงบรรยาย/สถิติเชิงปริมาณ การวิเคราะห์
เปรียบเทียบความแตกต่างของค่าเฉลี่ย และการวิเคราะห์ความเที่ยงของเครื่องมือการวิจัย 
 

2. การพิจารณาในการเลือกใช้สถิติที่เหมาะสมในการวิจัยเพื่อพัฒนาการเรียนรู้  
 2.1 ระดับการวัดของตัวแปร  
  ตัวแปร (Variable) เป็นสิ่ งที่ผู้ วิจัยต้องการศึกษา และเป็นสิ่งที่สามารถแปรค่าได้ ในกลุ่มประชากรหรือ                    
กลุ่มตัวอย่างที่ศึกษา สามารถแบ่งระดับการวัดของตัวแปรออกเป็น 4 ระดับ คือ มาตรานามบัญญัติ (Nominal Scale)    
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เป็นการกำหนดตัวเลขข้ึนเพื่อใช้ในการจำแนกสิ่งต่าง ๆ ออกเป็นกลุ่ม เป็นพวก หรือเป็นประเภท ซึ่งตัวเลขหรือค่าต่าง ๆ    
ที่กำหนดให้ไม่สามารถนำมากระทำทางคณิตศาสตร์ได้ เช่น ตัวแปรเพศ ระดับการศึกษา เป็นต้น 2) มาตราเรียงอันดับ 
(Ordinal Scale) เป็นการกำหนดอันดับให้แก่สิ่งต่าง ๆ  ช่วงความห่างของแต่ละอันดับไม่เท่ากันจึงไม่สามารถนำมากระทำ
ทางคณิตศาสตร์ได้ เช่น ตัวแปรลำดับที่การประกวด เป็นต้น 3) มาตราอันตรภาค (Ordinal Scale) เป็นการแบ่งค่าของตัว
แปรที่ต้องการศึกษาออกเป็นช่วง ๆ โดยแต่ละช่วงนั้นมีขนาดเท่ากัน และช่วงของความแตกต่างแต่ละช่วงเท่ากัน             
และสามารถบอกปริมาณความแตกต่างระหว่างช่วงได้ แต่ไม่มีศูนย์ที่แท้จริง (Absolute Zero) เป็นเพียงศูนย์เทียมหรือ           
ศูนย์สมมติ (arbitrary zero) เท่านั้น เช่น ตัวแปรอุณหภูมิ คะแนนสอบ เป็นต้น และ 4) มาตราอัตราส่วน (Ratio Scale)  
เป็นมาตราการวัดที่ตัวเลขเป็นผลการวัดที่ละเอียดที่สุด สามารถสื่อความหมายตรงตามค่าของสิ่งที่วัด และเป็นมาตรา
อัตราส่วนที่มีศูนย์แท ้เช่น ตัวแปรรายได้ เป็นต้น ซึ่งหากจัดแบ่งกลุ่มของตัวแปรทั้ง 4 ระดับออกเป็น 2 กลุ่ม สามารถจำแนก
ออกได้ ดังนี้ 1) ตัวแปรเชิงคุณลักษณะ หรือตัวแปรเชิงกลุ่ม ประกอบด้วยตัวแปรที่อยู่ในมาตรานามบัญญัติ และมาตรา            
เรียงอันดับ ซึ่งตัวเลขไม่มีความหมายทางคณิตศาสตร์ ไม่สามารถนำมาบวก ลบ คูณ หารได้ และ 2) ตัวแปรเชิงปริมาณ 
ประกอบด้วยตัวแปรที่อยู่ในมาตราอันตรภาคและมาตราอัตราส่วน ตัวเลขมีความหมายทางคณิตศาสตร์สามารถนำมา            
บวก ลบ คูณ หารได้ ทั้งนี้การวิเคราะห์ข้อมูลระดับการวัดของข้อมูลที่สูงกว่าจะมีคุณสมบัติครอบคลุมคุณสมบัติของค่าใน
มาตราที่ต่ำกว่าจึงสามารถแปลงค่าในมาตราที่สูงกว่าเป็นมาตราที่ต่ำกว่าได้  เช่น อายุ..... ปี ซึ่งเป็นข้อมูลที่อยู่ในระดับ
อัตราส่วน สามารถแปลงเป็นช่วงอายุ ซึ่งเป็นข้อมูลที่อยู่ในระดับนามบัญญัติได้  

2.2 การพิจารณาเลือกใช้สถิติท่ีเหมาะสมในการวิจัยเพ่ือพัฒนาการเรียนรู้   
 ในการวิเคราะห์ข้อมูลเพื่อตอบปัญหาการวิจัยเพื่อพัฒนาการเรยีนรู้ นั้นประกอบด้วยทั้งการวิเคราะห์ข้อมูลโดย
ใช้สถิติเชิงบรรยาย/สถิติเชิงปริมาณ (Descriptive Statistics) และการวิเคราะห์ข้อมูลโดยใช้สถิติเชิงอ้างอิง (Inferential 
Statistics) ดังนี ้

2.2.1 การวิเคราะห์ข้อมูลโดยใช้สถิติเชิงบรรยาย/สถิติเชิงปริมาณ  เพื่อบรรยายลักษณะของข้อมูลต่าง ๆ           
ทีร่วบรวมข้อมูลมา ได้แก่ การหาค่าความถี่ และค่าร้อยละ (กรณีข้อมูลเชิงกลุ่ม ซึ่งมีระดับการวัดของข้อมูลอยู่ในมาตรา
นามบัญญัติและมาตราเรียงอันดับ) และการหาค่าเฉลี่ย และค่าส่วนเบี่ยงเบนมาตรฐาน (กรณีข้อมูลเชิงปริมาณ ซึ่งมี
ระดับการวัดของข้อมูลอยู่ในมาตราอันตรภาคและมาตราอัตราส่วน)  

2.2.2 การวิเคราะห์ข้อมูลโดยใช้สถิติเชิงอ้างอิง ในบทความฉบับนี้จะกล่าวถึงเฉพาะการเปรียบเทียบความ
แตกต่างของค่าเฉลี่ยของกลุ่มตัวอย่าง สถิติที่ใช้ในการวิเคราะห์ คือ การทดสอบค่าที (T-Test) ทั้งนี้สามารถใช้สถิติ
ทดสอบค่าทีได้ในกรณีที่ตัวแปรต้นเป็นตัวแปรเชิงกลุ่ม (มีระดับการวัดของข้อมูลอยู่ในมาตรานามบัญญัติและมาตราเรียง
อันดับ) แปรค่าได้ 2 ค่า  และตัวแปรตามเป็นข้อมูลเชิงปริมาณ (มีระดับการวัดของข้อมูลอยู่ในมาตราอันตรภาคและ
มาตราอัตราส่วน)  เท่านั้น เช่น  เปรียบเทียบจำนวนครั้งการเข้าเรียนจำแนกตามเพศ (แปรค่าได้ 2 ค่า คือ ชาย และ 
หญิง) เปรียบเทียบผลสัมฤทธิ์ทางการเรียนจำแนกตามวิธีการจัดการเรียนรู้ 2 วิธี เป็นต้น  ซึ่งหากตัวแปรต้นเป็นข้อมูล          
เชิงกลุ่ม ที่มีการแปรค่า มากกว่า 2 ค่า ไม่สามารถใช้สถิติทดสอบค่าที่ได้ ควรปรับใช้สถิติในการวิเคราะห์ความแปรปรวน
ทางเดียว (ANOVA) ในกรณีที่ตัวแปรต้นแปรค่า 3 ค่า หรือสถิติวิเคราะห์ความแปรปรวนหลายทาง (MANOVA) ต่อไป ใน
กรณีที่ตัวแปรต้นแปรค่าได้มากกว่า 3 ค่าขึ้นไป  นอกจากนี้หากตัวแปรตามเป็นข้อมูลเชิงกลุ่ม จะไม่สามารถใช้สถิติ
ทดสอบค่าทีได้ ควรปรับใช้สถิติทดสอบไค-สแควร์ (Chi-Square) เช่น เปรียบเทียบการสอบ (แปรค่าได้ 2 ค่า คือ              
ผ่าน และไม่ผ่าน) จำแนกตามเพศ (แปรค่าได้ 2 ค่า คือ ชาย และหญิง) เป็นต้น 
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3. การวิเคราะห์ข้อมูลในการวิจัยเพื่อพัฒนาการเรียนรู้ โดยใช้โปรแกรม PSPP  
 โปรแกรม PSPP เป็นการทำงานภายใต้ระบบการปฏิบัติงานวินโดว์จึงใช้ความสามารถข้ันพ้ืนฐานของระบบปฎิบัติ

การวินโดว์ได้ เช่น การตัด การคัดลอก เป็นต้น สามารถนำข้อมูลเข้าได้จากหลายโปรแกรม เช่น WordPad Notepad  
และ Microsoft Office เป็นต้น มาใช้ในโปรแกรม PSPP ได้ นอกจากนี้ยังสามารถนำข้อมูลเข้าจากโปรแกรมอื่น ๆ โดย
ใช้คำสั่ง import data แต่โปรแกรม PSPP มีข้อจำกัดบางประการที่แตกต่างจากการใช้งานโปรแกรม SPSS คือ ในส่วน
ของการตั้งค่าของตัวแปร ในหน้าต่าง Variable View ไม่สามารถคัดลอกการตั้งค่าจากตัวแปรหนึ่งไปยังอีกตัวแปรหนึ่ง
ได้  โปรแกรม PSPP มีคำสั่งเครื่องมือพื้นฐานของโปรแกรมคล้ายกับโปรแกรม Microsoft  ในส่วนสำคัญที่เรียกใช้ ดังนี้ 
1) File ใช้สำหรับการจัดการเกี่ยวกับไฟล์ข้อมูล 2) Edit ใช้สำหรับย้าย คัดลอก จัดวางข้อมูล หรือค้นหาข้อมูลจากที่ต่าง ๆ 
3) Data ใช้สำหรับจัดการข้อมูล การเพิ่มตัวแปร การเพิ่มข้อมูล  4) Transform ใช้สำหรับย้ายหรือเปลี่ยนข้อมูลจากรูปแบบ
หนึ่งไปยังอีกรูปแบบ และการคำนวณค่า ซึ่งในการวิจัยเพื่อพัฒนาการเรียนรู้ส่วนใหญ่จะเป็นการใช้เพื่อหาค่ารวมของตัวแปร 
5) Analyze ใช้สำหรับเลือกใช้สถิติในการวิเคราะห์ข้อมูล ซึ่งในตอบปัญหาการวิจัยเพื่อพัฒนาการเรียนรู้ส่วนใหญ่จะเป็น
การใช้ คำสั่ ง Descriptive Compare Mean และ Reliability Analysis และ 6) Graphs ใช้สำหรับสร้างกราฟ                  
และแผนภูมิต่าง ๆ นอกจากนี้การจัดการข้อมูลในโปรแกรม PSPP สามารถดำเนินการได้คล้ายกับโปรแกรม SPSS คือ 
หากต้องการแทรก หรือลบ Case สามารถดำเนินการได้ 2 แบบคือ ใช้คำสั่ง Edit → Insert Case หรือ คลิกขวาที่             
แถบเคสด้านซ้าย เลือก Insert Case ในกรณีที่ต้องการเพิ่มเคส และ ใช้คำสั่ง Edit → Clear Case หรือ คลิกขวาที่            
แถบเคสด้านซ้าย เลือก Clear Case ในกรณีที่ต้องการลบเคส  และหากต้องการแทรกหรือลบตัวแปร สามารถ
ดำเนินการได้ 2 แบบเช่นกัน คือ ใช้คำสั่ง Edit → Insert Variable หรือ คลิกขวาที่แถบตัวแปรด้านบน เลือก Insert 
Variable ในกรณีที่ต้องการเพิ่มตัวแปร และ ใช้คำสั่ง Edit → Clear Variable หรือ คลิกขวาที่แถบตัวแปรด้านบน เลือก 
Clear Variable ในกรณีที่ต้องการลบตัวแปร 
  หน้าต่างของโปรแกรม PSPP มีแผ่นงานของโปรแกรม 2 แผ่นงาน คือ 1) แผ่นงาน Data View ใช้สำหรับการบันทึก
ข้อมูลผลการเก็บรวบรวมข้อมูล โดยบันทึกข้อมูลทีละ Case จากซ้ายไปขวาจนครบทุกตัวแปร เช่น หากรวบรวมข้อมูล
จากผู้ตอบ 20 คน จะบันทึกข้อมูลถึง Case ที่ 20 เและ 2) แผ่นงาน variable view ใช้สำหรับการตั้งค่าตัวแปรให้
สอดคล้องกับเครื่องมือในการวิจัย มีส่วนสำคัญที่ต้องตั้งค่าตัวแปรดังภาพที่ 1       

1) Name เป็นการกำหนดชื่อตัวแปร สามารถกำหนดชื่อตัวแปรไดท้ั้งภาษาอังกฤษ ภาษาไทย และตัวเลข โดย
การตั้งช่ือน้ันต้องขึ้นต้นด้วยตัวอักษร   

2) Type เป็นการกำหนดชนิดของตัวแปร โดยส่วนใหญ่แล้วหากเป็นข้อมูลที่เป็นตัวเลข กำหนดเป็น Numeric 
และหากเป็นข้อมูลที่ได้จากแบบสอบถามปลายเปิด หรือข้อมูลที่ต้องการบันทึกเป็นตัวอักษร ให้ปรับเป็น String   

3) Value Labels เป็นการกำหนดค่าที่เป็นไปได้ให้กับตัวแปร เช่น ตัวแปรระดับการศึกษา แปรค่าได้ 2 ค่า 
คือ ปริญญาตรี ปริญญาโท และปริญญาเอก จึงมีการกำหนดตัวเลขแทนค่า ซึ่งสามารถกำหนดเป็นตัวเลขใด ๆ ก็ได้             
แต่เพื่อให้สะดวกในการบันทึกข้อมูลนิยมกำหนดเรียงตามลำดับข้อรายการกำหนดให้ 1 แทนระดับปริญญาตรี               
2 แทนระดับปริญญาโท และ 3 แทนระดับปริญญาเอก แต่หากเป็นตัวแปรต่อเนื่องไม่ต้องกำหนดค่าที่เป็นไปได้ให้ กับ            
ตัวแปร เช่น ตัวแปรอายุ ... ปี ไม่ต้องบันทึกข้อมูลใด ๆ ในช่อง Value Labels    

4) Missing Values เป็นการกำหนดค่าให้กับข้อมูลสูญหาย   
5) Measure เป็นการตั้งค่าระดับการวัดของตัวแปร โดยกำหนดให้สอดคล้องกับมาตราวัดของตัวแปร ดังนี้ 

มาตรานามบัญญัติ เลือก Nominal มาตราเรียงอันดับ เลือก Ordinal มาตราอันตรภาพและมาตราอัตราส่วน คลิกเลือก 
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Scale  เช่น ตัวแปรระดับการศึกษา คลิกเลือก “Nominal” ลำดับที่การประกวดโครงงาน คลิกเลือก “Ordinal”  
คะแนน คลิกเลือก “Scale” เป็นต้น 

 

 
ภาพที่ 1 เมนูคำสั่งพ้ืนฐานของโปรแกรม 

การวิเคราะห์ข้อมูลโดยใช้สถิติเชิงบรรยาย/สถิติเชิงปริมาณ  เพื่อตอบปัญหาการวิจัยเพื่อพัฒนาการเรียนรู้
เกี่ยวกับความคิดเห็นของผู้มีส่วนเกี่ยวข้อง และในการบรรยายลักษณะของข้อมูลต่าง ๆ ที่เกี่ยวข้อง ได้แก่ การหาค่าความถี่ 
และค่าร้อยละ และการหาค่าเฉลี่ย และค่าส่วนเบี่ยงเบนมาตรฐาน มีวิธีการในการวิเคราะห์ข้อมูลโดยใช้โปรแกรม PSPP ดังนี ้

 
3.1 การหาค่าความถี่แบบทางเดียว และค่าร้อยละ 

  การวิเคราะห์หาค่าความถี่แบบทางเดียวและค่าร้อยละ มีขั้นตอนในการวิเคราะห์ ดังนี้ 1) คลิกเลือกคำสั่ง 
Analyze → Descriptive Statistics → Frequencies  2) คลิกเลือกตัวแปรที่ต้องการหาค่าความถี่และค่าร้อยละ            
จากกล่องด้านซ้ายมือไปไว้กล่องทางขวามือ (Variables) 3) คลิกตรงช่อง Mean และ Standard deviation เพื่อนำออก           
ไม่วิเคราะห์ค่าเฉลี่ยและค่าส่วนเบี่ยงเบนมาตรฐาน  4) หากต้องการนำเสนอแผนภูมิ คลิกที่ Charts  และ 5)  คลิก OK                  
วิธีการวิเคราะห์ ดังภาพที่ 2 และตัวอย่างผลการวิเคราะห์ข้อมูล ดังภาพที่ 3 
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ภาพที่ 2 วิธีการวิเคราะหค์่าความถี่แบบทางเดียว 

 

ภาพที่ 3 ตัวอย่างผลการวเิคราะหค์วามถี่แบบทางเดียว และค่าร้อยละ 
  

              การนำเสนอผลการวิเคราะห์ความถี่แบบทางเดียวและค่าร้อยละในรูปของการบรรยายประกอบตาราง      
ซึ่งการบรรยายผลนิยมบรรยาย 3 ค่า คือ สูงสุด รองลงมา และต่ำที่สุด  ซึ่งจากตัวอย่างผลการวิเคราะห์ความถี่แบบทาง
เดียวในภาพท่ี 3 สามารถนำเสนอผลการวิเคราะห์ข้อมูลในรูปแบบตารางประกอบการบรรยาย ได้ดังตารางที่ 1  
 
ตารางที่ 1 จำนวนและร้อยละของเพศ 

เพศ จำนวน ร้อยละ 
ชาย 5 33.33 
หญิง 10 67.67 
รวม 15 100.00 

 

  จากตารางที่ 1 เมื่อพิจารณาจำนวนและร้อยละของเพศของผู้ตอบ พบว่า ผู้ตอบส่วนใหญ่เป็นเพศหญิง               
โดยจำนวน เท่ากับ 10 คน คิดเป็นร้อยละ 67.67 รองลงมา คือ เพศชาย จำนวนเท่ากับ 5 คน คิดเป็นร้อยละ 33.33 
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การหาค่าเฉลี่ย และค่าส่วนเบี่ยงเบนมาตรฐาน 
  การวิเคราะห์หาค่าเฉลี่ย และค่าส่วนเบี่ยงเบนมาตรฐานมีขั้นตอนในการวิเคราะห์ ดังนี้ 1) คลิก เลือกคำสั่ง 
Analyze → Descriptive Statistics → Descriptive Statistics 2) คลิกเลือกตัวแปรที่ต้องการหาค่าเฉลี่ย และ            
ค่าส่วนเบี่ยงเบนมาตรฐานจากกล่องด้านซ้ายมือไปไว้กล่องทางขวามือ (Variables)  และ 3) คลิก OK  วิธีการวิเคราะห์ 
ดังภาพท่ี 4 และตัวอย่างผลการวิเคราะห์ข้อมูล ดังภาพที่ 5 

 

ภาพที่ 4 วิธีการวิเคราะหค์่าเฉลี่ย และค่าส่วนเบี่ยงเบนมาตรฐาน 

 

ภาพที่ 5 ตัวอย่างผลการวเิคราะหค์่าเฉลี่ย และค่าส่วนเบี่ยงเบนมาตรฐาน 
 
               การนำเสนอผลการวิเคราะห์ค่าเฉลี่ย และค่าส่วนเบี่ยงเบนมาตรฐานในรูปของการบรรยายประกอบตาราง 
ซึ่งการบรรยายผลนิยมบรรยาย 3 ค่า คือ สูงสุด รองลงมา และต่ำที่สุด และกำหนดเกณฑ์ในแปลความหมาย ซึ่งอาจจะ
เป็นเกณฑ์แบบช่วงเท่า (4.21-5.00 ระดับมากที่สุด 3.81-4.20 ระดับมาก 2.61-3.80 ระดับปานกลาง 1.81-2.60     
ระดับน้อย และ 1.00-1.80 ระดับน้อยที่สุด) หรือช่วงไม่เท่า (4.51-5.00 ระดับมากท่ีสุด 3.51-4.50 ระดับมาก 2.51-3.50 
ระดับปานกลาง 1.51-2.50 ระดับน้อย และ 1.00-1.50 ระดับน้อยท่ีสุด) ซึ่งขึ้นอยู่กับผู้วิจัยเลือกใช้เกณฑ์ ซึ่งจากตัวอย่าง           
ผลการวิเคราะห์ในภาพที่ 5 ผู้เขียนนำเสนอผลโดยเปรียบเทียบกับเกณฑ์แบบช่วงเท่า ใน 5 ระดับ ดังตัวอย่างการ
นำเสนอในตารางที่ 2 
 
 
 



156                                                                                  วารสารวิจัยราชภัฏกรุงเก่า ปีที่ 9 ฉบับที่ 1 มกราคม-เมษายน 2565 
 

ตารางที่ 2 ค่าเฉลี่ยและคา่เบี่ยงเบนมาตรฐานของความพึงพอใจของผู้เข้าร่วมโครงการ 

ข้อรายการ ค่าเฉลี่ย ค่าส่วนเบี่ยงเบนมาตรฐาน การแปลความหมาย 

ด้านสถานที ่ 3.80 .68 ระดับปานกลาง 

ด้านสิ่งอำนวยความสะดวก 3.87 .74 ระดับมาก 

ด้านบุคลากร 4.47 .74 ระดับมากที่สุด 

ด้านความสะอาด 4.40 .80 ระดับมากที่สุด 

ด้านวิทยากร 4.07 .70 ระดับมาก 

รวม 4.08 .35 ระดับมาก 
  

จากตารางที่ 2 เมื่อพิจารณาค่าเฉลี่ยและค่าเบี่ยงเบนมาตรฐานของความคิดเห็นของผู้เข้าร่วมโครงการ พบว่า 
ในภาพรวมผู้เข้าร่วมโครงการมีความพึงพอใจอยู่ในระดับมาก โดยมีค่าเฉลี่ยเท่ากับ 4.08 และมีค่าส่วนเบี่ยงเบน
มาตรฐาน เท่ากับ 0.35  และเมื่อพิจารณาจำแนกรายข้อรายการ พบว่า ข้อรายการที่ผู้เข้าร่วมโครงการส่วนใหญ่มีความ
คิดเห็นในระดับสูงสุด คือ ด้านบุคลากร โดยมีค่าเฉลี่ยเท่ากับ 4.47 และมีค่าส่วนเบี่ยงเบนมาตรฐาน เท่ากับ 0.74 
รองลงมา คือ ด้านความสะอาด โดยมีค่าเฉลี่ยเท่ากับ 4.40 และมีค่าส่วนเบี่ยงเบนมาตรฐาน เท่ากับ 0.80 และน้อยที่สุด 
คือ ด้านสถานที่ โดยมีค่าเฉลี่ยเท่ากับ 3.80 และมีค่าส่วนเบี่ยงเบนมาตรฐาน เท่ากับ 0.68 ตามลำดับ 

การวิเคราะห์เปรียบเทียบความแตกต่างของค่าเฉลี่ย  
       การเปรียบเทียบความแตกต่างของค่าเฉลี่ยของกลุ่มตัวอย่าง เพื่อตอบปัญหาการวิจัยหลัก ทั้งกรณีเปรียบเทียบ
ความแตกต่างของค่าเฉลี่ยของกลุ่มตัวอย่างที่ไม่เป็นอิสระ ซึ่งสถิติที่ใช้ในการวิเคราะห์ คือ การทดสอบค่าทีแบบกลุ่มตัวอย่าง
ไม่เป็นอิสระ (Dependent Samples T-Test) และกรณีเปรียบเทียบความแตกต่างของค่าเฉลี่ยกลุ่มตัวอย่าง 2 กลุ่มที่เป็น
อิสระ  สถิติที่ใช้ในการวิเคราะห์ คือ การทดสอบค่าทีแบบกลุ่มตัวอย่างเป็นอิสระ (Independent Samples T-Test) ดังนี ้

1) การทดสอบค่าทีแบบกลุ่มตัวอย่างไม่เป็นอิสระ (Dependent Samples T-Test) 
     การวิเคราะห์เปรียบเทียบค่าเฉลี่ยของกลุ่มตัวอย่างที่ไม่เป็นอิสระ เช่น การเปรียบเทียบคะแนนก่อนเรียนและ

คะแนนหลังเรียน มีขั้นตอนในการวิเคราะห์ ดังนี้ 1) คลิกเลือกคำสั่ง Analyze → Compare Means → Paired Samples 
T -Test  2) คลิกเลือกตัวแปรที่ต้องการเปรียบเทียบความแตกต่างของค่าเฉลี่ยจากกล่องด้านซ้ายมือไปไว้กล่องทางขวามือ 
(Test Paired) และ 3) คลิก OK  วิธีการวิเคราะห์ ดังภาพที่ 6 และตัวอย่างผลการวิเคราะห์ข้อมูล ดังภาพที่ 7 
  

 
ภาพที่ 6 วิธีการวิเคราะหเ์ปรียบเทียบค่าเฉลีย่ของกลุ่มตัวอย่าง 2 กลุ่มที่ไม่เป็นอิสระ 
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ภาพที่ 7 ตัวอย่างผลการวิเคราะหเ์ปรียบเทยีบค่าเฉลี่ยของกลุ่มตัวอย่าง 2 กลุ่มที่ไม่เป็นอสิระ 

 

              การนำเสนอผลการวิเคราะห์ในรูปของการบรรยายประกอบตาราง ซึ่งจากตัวอย่างผลการวิเคราะห์ในภาพท่ี 7 
ผู้เขียนนำเสนอผลการวิเคราะห์ได้ดังตารางที่ 3 
 

ตารางที่ 3  ผลการวเิคราะห์เปรียบเทียบค่าเฉลี่ยของผลสัมฤทธ์ิทางการเรยีนระหวา่งผู้เรียนท่ีได้รับการจัดการเรยีนรู้โดย
ใช้นวัตกรรมกับผูเ้รียนทีไ่ดร้ับการจัดการเรียนรู้โดยวิธีปกติ   
 

คะแนน ค่าเฉลี่ย ค่าส่วนเบี่ยงเบน
มาตรฐาน 

ค่า t Sig. 

คะแนนก่อนเรียน 14.95 1.61 7.55 .00 
คะแนนหลังเรียน 16.95 1.65 

df = 18 

  จากตารางที่ 3 พบว่า ค่า t มีค่าเท่ากับ 7.55 และค่า Sig. มีค่า .000  ซึ่งมีค่าน้อยกว่าค่านัยสำคัญที่กำหนดไว้ 
ดังนั้นคะแนนก่อนเรียนมีความแตกต่างจากคะแนนหลังเรียนอย่างมีนัยสำคัญ ท่ีระดับนัยสำคัญ .05 และเมื่อพิจารณา
ค่าเฉลี่ยของคะแนน พบว่า คะแนนหลังเรียนมีคะแนนสูงกว่าคะแนนก่อนเรียน 

2) การทดสอบค่าทีแบบกลุ่มตัวอย่างเป็นอิสระ (Independent Samples T-Test) 
       การวิเคราะห์เปรียบเทียบค่าเฉลี่ยของกลุ่มตัวอย่างที่ เป็นอิสระ เช่น การเปรียบเทียบผลสัมฤทธิ์ทาง              
การเรียนของนักเรียน 2 กลุ่ม (กลุ่มที่ได้รับการจัดการเรียนรู้โดยใช้นวัตกรรม และกลุ่มที่ได้รับการจัดการเรียนรู้แบบปกติ)             
มีขั้นตอนในการวิเคราะห์  ดังนี้  1) คลิกเลือกคำสั่ ง Analyze → Compare Means → Independent  Samples           
T- Test   2) คลิกเลือกตัวแปรที่ต้องการเปรียบเทียบความแตกต่างของค่าเฉลี่ยจากกล่องด้านซ้ายมือไปไว้กล่องทางขวามือ 
โดยนำตัวแปรตามไว้กล่อง Test Variable และตัวแปรอิสระไว้กล่อง Grouping Variable 3) คลิก Define Groups 4) ระบุ
ค่าที่กำหนดไว้ของตัวแปรต้นของกลุ่มตัวอย่างกลุ่มที่ 1 และกลุ่มที่ 2  4) คลิก Continue และ 5) คลิก OK  วิธีการวิเคราะห์ 
ดังภาพที่ 8 และตัวอย่างผลการวิเคราะห์ข้อมูล ดังภาพที่ 9 
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ภาพที่ 8 วิธีการวิเคราะหเ์ปรียบเทียบค่าเฉลีย่ของกลุ่มตัวอย่าง 2 กลุ่มที่เป็นอิสระกัน 

 

ภาพที่ 9 ตัวอย่างผลการวเิคราะหเ์ปรียบเทยีบค่าเฉลี่ยของกลุ่มตัวอย่าง 2 กลุ่มที่เป็นอิสระกัน 
 

              การนำเสนอผลการวิเคราะห์ในรูปของการบรรยายประกอบตาราง ซึ่งจากตัวอย่างผลการวิเคราะห์ในภาพที่ 
9 ผู้เขียนนำเสนอผลการวิเคราะหไ์ด้ดังตารางที่ 4 
 
ตารางที่ 4  ผลการวเิคราะห์เปรียบเทียบค่าเฉลี่ยของผลสัมฤทธ์ิทางการเรยีนระหวา่งผู้เรียนท่ีได้รับการจัดการเรยีนรู้โดย
ใช้นวัตกรรมกับผูเ้รียนทีไ่ดร้ับการจัดการเรียนรู้โดยวิธีปกติ   
 

ผลสัมฤทธ์ิทางการเรียน ค่าเฉลี่ย ค่าส่วนเบี่ยงเบน
มาตรฐาน 

ค่า t Sig. 

การจัดการเรยีนรู้โดยใช้นวัตกรรม 76.47 1.30 7.80 .00 
การจัดการเรยีนรู้โดยวิธีปกต ิ 67.87 .98 

df = 28 



ARU Research Journal, Vol.9, No.1, January- April 2022                                                                                            159 

 

 จากตารางที่ 4 พบว่า ค่า T มีค่าเท่ากับ 7.80 และค่า Sig. มีค่า .000 ซึ่งมีค่าน้อยกว่าค่านัยสำคัญที่กำหนดไว้ 
ดังนั้นผลสัมฤทธิ์ทางการเรียนระหว่างผู้เรียนที่ได้รับการจัดการเรียนรู้โดยใช้นวัตกรรมมีความแตกต่างกับผู้เรียนที่ได้รับ
การจัดการเรียนรู้โดยวิธีปกติ อย่างมีนัยสำคัญที่ระดับนัยสำคัญ .05 และเมื่อพิจารณาค่าเฉลี่ย พบว่า ผลสัมฤทธิ์ทางการเรียน
ของผู้เรียนที่ได้รับการจัดการเรียนรู้โดยใช้นวัตกรรมสูงกว่าผลสัมฤทธิ์ทางการเรียนของผู้เรียนที่ได้รับการจัดการเรียนรู้
โดยวิธีปกติ 
  การวิเคราะห์ความเที่ยงของเคร่ืองมือการวิจัย 
 การวิเคราะห์ความเที่ยงของเครื่องมือการวิจัย เป็นการตรวจสอบคุณภาพของเครื่องมือการวิจัยที่มีความสำคัญ
เป็นอย่างยิ่งต่อการดำเนินการวิจัยเพื่อพัฒนาการเรียนรู้ เนื่องจากหากเครื่องมือไม่มีคุณภาพผลที่ได้จากการวัดก็จะมี
ความคลาดเคลื่อนส่งผลให้การวิจัยไม่มีความน่าเชื่อถือ ซึ่งค่าความเที่ยงหรือความเชื่อมั่น (Reliability) คือคุณสมบัติของ
เครื่องมือในการวัดได้ผลคงที่ การหาค่าความเที่ยงน้ันมีหลายประเภท ได้แก่ 1) ความเที่ยงแบบคงที่จากการใช้วิธีทดสอบ
ซ้ำแล้วนำคะแนนที่ได้มาหาค่าสัมประสิทธิ์สหสัมพันธ์แบบเพียร์สัน 2) ความเที่ยงแบบสมมูลจากการใช้วิธีเครื่องมือ
คู่ขนานแล้วนำคะแนนที่ได้มาหาค่าสัมประสิทธิ์สหสัมพันธ์แบบเพียร์สัน 3) ความเที่ยงแบบคงที่และสมมูลจากการทดสอบซ้ำ
โดยใช้เครื่องมือคู่ขนานแล้วนำคะแนนที่ได้มาหาค่าสัมประสิทธิ์สหสัมพันธ์แบบเพียร์สัน 4) วิธีการแบ่งครึ่งข้อสอบ              
เป็นการใช้เครื่อมือชุดเดียวสอบครั้งเดียว โดยแบ่งออกเป็น 2 ชุด เช่น ข้อคู่กับข้อคี่ หรือแบบครึ่งแรกกับครึ่งหลัง                
นำคะแนนที่ได้มาหาค่าสัมประสิทธ์ิสหสัมพันธ์แบบเพียร์สัน แล้วปรับให้เป็นเต็มฉบับโดยใช้สูตรสัมประสิทธ์ิสหสัมพันธ์
ของสเปียร์แมน บราวน์ 5) วิธีของคูเดอร์ ริชาร์ดสัน เป็นการหาความเที่ยงแบบความสอดคล้องภายใน แต่สามารถใช้ได้
เฉพาะข้อสอบที่มีการให้คะแนนแบบ 0,1 (ตอบถูกได้ 1 คะแนน ตอบผิดได้ 0 คะแนน) ซึ่งสามารถวิเคราะห์ใช้โปรแกรม
วิเคราะห์ข้อสอบ เช่น โปรแกรม Tab โปรแกรม EVANA เป็นต้น และ 6) วิธีการหาค่าสัมประสิทธ์ิแอลฟาของครอนบาค 
เป็นการหาค่าความเที่ยงแบบความสอดคล้องภายในสามารถวิเคราะห์ได้ทุกเครื่องมือการวิจัย 
              ซึ่งในบทความนี้ผู้เขียนขอกล่าวถึงเฉพาะการวิเคราะห์ค่าความเที่ยงด้วยวิธีการหาค่าสัมประสิทธิ์แอลฟา
ของครอนบาค มีขั้นตอนในการวิเคราะห์ ดังนี้ 1) คลิกเลือกคำสั่ง Analyze → Reliability (ในบางเวอร์ช่ันอาจคลิก
เลือกคำสั่ง Analyze → Scale → Reliability)  2) คลิกเลือกตัวแปรที่ต้องการหาค่าความเที่ยงจากกล่องด้านซ้ายมือ
ไปไว้กล่องทางขวามือ (Items) 3) คลิก OK  วิธีการวิเคราะห์ ดังภาพที่ 10 และตัวอย่างผลการวิเคราะห์ข้อมูล ดังภาพที่ 11 

 
ภาพที่ 10 วิธีการวิเคราะห์ค่าความเที่ยงด้วยวิธีการหาค่าสมัประสิทธิ์แอลฟาของครอนบาค 
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ภาพที่ 11 ตัวอย่างผลการวิเคราะห์ค่าความเที่ยงด้วยวิธีการหาคา่สมัประสิทธ์ิแอลฟาของครอนบาค 
 

               การนำเสนอผลการวิเคราะห์ในรูปของการบรรยายประกอบตาราง ซึ่งจากตัวอย่างผลการวิเคราะห์ในภาพที่ 
11 ผู้เขียนนำเสนอผลการวิเคราะห์ได้ดังตารางที่5  
 

ตารางที่ 5 ค่าความเที่ยงของเครื่องมือ 

 

เครื่องมือวิจัย จำนวนข้อคำถาม ค่าความเที่ยงแบบสมัประสิทธิ์แอลฟ่าของครอนบาค 

แบบสอบถามความพึงพอใจของนักเรียน 10  .02 
 

 จากตารางที่ 5 พบว่า เมื่อพิจารณาค่าความเที่ยงของแบบสอบถามความพึงพอใจของนักเรียน พบว่า มีค่า
ความเที่ยงเท่ากับ 0.02 

ในบทความนี้ผู้เชียนยกตัวอย่างเพื่อประกอบการอธิบายโดยใช้การวิจัย เรื่อง การพัฒนาผลสัมฤทธิ์ทางการ
เรียนโดยใช้นวัตกรรมการเรียนรู้ 4.0 ของนักศึกษาหลักสูตรครุศาสตรบัณฑิต คณะครุศาสตร์ มหาวิทยาลัยราชภัฎ
พระนครศรีอยุธยา โดยมีวัตถุประสงค์การวิจัย ดังนี้ 1) เพื่อเปรียบเทียบผลสัมฤทธิ์ทางการเรียนของนักศึกษาก่อนและหลัง
การได้รับการจัดการเรยีนรู้โดยใช้นวัตกรรมการเรยีนรู้ 4.0 และ 2) เพื่อศึกษาความพึงพอใจของนักศึกษาที่มีต่อการจัดการเรียนรู้
โดยใช้นวัตกรรมการเรียนรู้ 4.0 และเครื่องมือที่ใช้ในการวิจัย ประกอบด้วย 1) แบบทดสอบวัดผลสัมฤทธิ์ทางการเรียน 
ซึ่งมีลักษณะเป็นแบบปรนัยแบบเลือกตอบ (Multiple Choice) จำนวน 30 ข้อ และ 2) แบบสอบถามความพึงพอใจของ
นักศึกษาที่มีต่อการจัดการเรียนรู้โดยใช้นวัตกรรมการเรียนรู้ 4.0 ซึ่งมีลักษณะเป็นแบบมาตราส่วนประมาณค่า 5 ระดับ
ของลิเคอร์ท (Likert’s rating scale) จำนวน 8 ข้อ ดังนี้  1) ข้อมูลสถานภาพทั่วไปของผู้ตอบ ประกอบด้วยข้อคำถาม 
3 ข้อ ได้แก่ เพศ คณะ ช้ันปี และ 2) ข้อมูลความพึงพอใจของนักศึกษา ประกอบด้วยข้อคำถาม 5 ข้อ ได้แก่ ด้านสถานท่ี 
ด้านสิ่งอำนวจความสะดวก ด้านบุคลากร ด้านความสะอาด และด้านวิทยากร  ดังตัวอย่างในการตั้งค่าตัวแปรดังนี้  

1. Name  กำหนดช่ือตามข้อคำถาม เพศ คณะ ช้ันปี ด้านสถานที่ ด้านสิ่งอำนวยความสะดวก ด้านบุคลากร 
ด้านความสะอาด และด้านวิทยากร     

2. Type กำหนดเป็น Numeric  
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3. Value Labels กำหนดค่าที่เป็นไปได้ให้กับตัวแปร เช่น ตัวแปรเพศ กำหนดให้ 1 แทน “ชาย” และ 2 แทน 
“หญิง” เป็นต้น  

4. Missing Values กำหนดค่าเป็นเลข 8 
5. Measure  1) ข้อคำถามข้อมูลสถานภาพทั่วไป เช่น เพศ คณะ ช้ันปี กำหนดเป็น Nominal และ 2) ข้อคำถาม

ความพึงพอใจของนักศึกษา กำหนดเป็น Scale 
    จากตัวอย่างข้างต้นการวิเคราะห์ข้อมูลเพื่อตอบปัญหาการวิจัย ดังนี้ 1) การวิเคราะห์เปรียบเทียบผลสัมฤทธ์ิ
ทางการเรียนของนักศึกษาก่อนและหลังการได้รับการจัดการเรียนรู้โดยใช้นวัตกรรมการเรียนรู้ 4.0 โดยใช้สถิติเชิงอ้างอิง
ในการเปรียบเทียบความแตกต่างของค่าเฉลี่ยของกลุ่มตัวอย่าง ได้แก่ ค่าสถิติ T แบบกลุ่มตัวอย่างไม่เป็นอิสระ (โดยใช้
คำสั่งในการวิเคราะห์ข้อมูลโดยใช้โปรแกรม PSPP คือ Paired Samples T-Test)  และ 2) การวิเคราะห์ความพึงพอใจของ
นักศึกษาที่มีต่อการจัดการเรียนรู้โดยใช้นวัตกรรมการเรียนรู้ 4.0 โดยใช้สถิติเชิงบรรยาย ได้แก่ ค่าเฉลี่ย และค่าส่วนเบี่ยงเบน 
มาตรฐาน (โดยใช้คำสั่งในการวิเคราะห์ข้อมูลโดยใช้โปรแกรม PSPP คือ Descriptive)     
 

3. บทสรุป  
 การวิเคราะห์ข้อมูลในการวิจัยเพื่อพัฒนาการเรียนรู้โดยใช้โปรแกรม PSPP  มีลักษณะของโปรแกรมคล้ายคลึง
กับโปรแกรม SPSS ซึ่งเป็นโปรแกรมสำเร็จรูปทางสถิติที่มีค่าใช้จ่าย  ซึ่งเมื่อวิเคราะห์ข้อดีและข้อจำกัดในการใช้
โปรแกรม ในการวิเคราะห์ข้อมูลระหว่างโปรแกรม PSPP เมื่อเปรียบเทียบกับโปรแกรมที่ใช้วิเคราะห์ข้อมูลอย่าง
แพร่หลาย โปรแกรม SPSS นั้น พบว่า ข้อดีของ โปรแกรม PSPP คือ โปรแกรมสำเร็จรูปทางสถิติที่ไม่มีค่าใช้จ่าย 
สามารถวิเคราะห์ข้อมูลเพื่อตอบปัญหาในการวิจัยเพื่อพัฒนาการเรียนรู้ได้อย่างครบถ้วนตามวัตถุประสงค์การวิจัย ได้ผล
การวิเคราะห์ข้อมูลที่ถูกต้องสมบูรณ์ แต่มีข้อจำกัดบางประการ คือ ในส่วนของหน้าต่างการตั้งค่าตัวแปร (Variable 
View) นั้นไม่สามารถคัดลอกข้อมูลจากตัวแปรหนึ่งไปยังอีกตัวแปรหนึ่งได้  การใช้โปรแกรม PSPP ในการตอบปัญหาการวิจัย
เพื่อพัฒนาการเรียนรู้นั้น สรุปได้ดังนี้ 
 

1. การพิจารณาในการเลือกใช้สถิติที่เหมาะสมในการวิจัยเพื่อพัฒนาการเรียนรู้ ดังน้ี 
  1)  ระดับการวัดของตัวแปร  มาตราการวัดของข้อมูลประกอบด้วย 4 มาตรา คือ มาตรานามบัญญัติ 
มาตราเรียงอันดับ มาตราอันตรภาค และมาตราอัตราส่วน ซึ่งมาตรานามบัญญัติและมาตราเรียงอันดับ เรียกว่า ข้อมูล
เชิงกลุ่ม เนื่องจากตัวเลขไม่สามารถนำมาบวก ลบ คูณ หารได้  ส่วนมาตราอันตรภาพและมาตราอัตราส่วน เรียกว่า 
ข้อมูลเชิงปริมาณ เนื่องจากตัวเลขสามารถนำมาบวก ลบ คูณ หาร ได้ 
 2) เทคนิคการเลือกใช้สถิติที่เหมาะสมในการวิจัยเพื่อพัฒนาการเรียนรู้ โดยการวิเคราะห์ข้อมูลโดยใช้สถิติ
เชิงบรรยาย/สถิติเชิงปริมาณ ในกรณีข้อมูลเชิงกลุ่ม (มาตรานามบัญญัติและมาตราเรยีงอันดับ) นิยมหาค่าความถี่ และค่า
ร้อยละ และในกรณีข้อมูลเชิงปริมาณ (มาตราอันตรภาพและมาตราอัตราส่วน) นิยมหาค่าเฉลี่ย และค่าส่วนเบี่ยงเบน
มาตรฐาน (กรณีข้อมูลเชิงปริมาณ ซึ่งมีระดับการวัดของข้อมูลอยู่ในมาตราอันตรภาคและมาตราอัตราส่วน) นอกจากน้ีใน
การวิเคราะห์เปรียบเทียบความแตกต่างของค่าเฉลี่ยของกลุ่มตัวอย่าง สถิติที่ใช้ในการวิเคราะห์ คือ การทดสอบค่าที            
(t-test) สามารถใช้ได้ในกรณีที่ตัวแปรต้นเป็นตัวแปรเชิงกลุ่ม แปรค่าได้ 2 ค่า และตัวแปรตามเป็นข้อมูลเชิงปริมาณ 
เท่านั้น เช่น  การเปรียบเทียบจำนวนครั้งการเข้าเรียนจำแนกตามเพศ (แปรค่าได้ 2 ค่า คือ ชาย และ หญิง)  การเปรียบเทียบ
ผลสัมฤทธิท์างการเรียนจำแนกตามวิธีการจัดการเรียนรู้ 2 วิธี เป็นต้น   
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2. วิธีการในการวิเคราะห์ข้อมูลในการวิจัยเพื่อพัฒนาการเรียนรู้ โดยใช้โปรแกรม PSPP ได้แก่ การวิเคราะห์
ข้อมูลโดยใช้สถิติเชิงบรรยาย/สถิติเชิงปริมาณ การวิเคราะห์เปรียบเทียบความแตกต่างของค่าเฉลี่ย และการวิเคราะห์
ความเที่ยงของเครื่องมือการวิจัย  สรุปขั้นตอนการวิเคราะห์ดังนี้ 
 1) การวิเคราะห์ข้อมูลโดยใช้สถิติเชิงบรรยาย/สถิติเชิงปริมาณ เพื่อตอบปัญหาการวิจัยที่เกี่ยวกับความ
คิดเห็นของผู้มีส่วนเกี่ยวข้อง และการบรรยายลักษณะของข้อมูลต่าง ๆ ที่เกี่ยวข้อง ได้แก่ การวิเคราะห์ค่าความถี่ ค่าร้อย
ละ ขั้นตอนการวิเคราะห์ คือ Analyze → Descriptive Statistics → Frequency และการวิเคราะห์ค่าเฉลี่ย และ         
ค่าส่ วนเบี่ ยงเบนมาตรฐาน ขั้นตอนการวิ เคราะห์  คือ  Analyze → Descriptive Statistics → Descriptive 
Statistics 

 2) การวิเคราะห์เปรียบเทียบความแตกต่างของค่าเฉลี่ยของกลุ่มตัวอย่าง เพื่อตอบปัญหาการวิจัยหลัก 1) 
เปรียบเทียบความแตกต่างของค่าเฉลี่ยของกลุ่มตัวอย่างที่ไม่เป็นอิสระ ซึ่งสถิติที่ใช้ในการวิเคราะห์ คือ การทดสอบค่าที
แบบกลุ่มตัวอย่างไม่เป็นอิสระ (dependent samples t-test) ขั้นตอนการวิเคราะห์ คือ Analyze → Compare 
Means → Paired Samples T Test   และ 2) เปรียบเทียบความแตกต่างของค่าเฉลี่ยกลุ่มตัวอย่าง 2 กลุ่มที่เป็น
อิสระ  สถิติที่ใช้ในการวิเคราะห์ คือ การทดสอบค่าทีแบบกลุ่มตัวอย่างเป็นอิสระ (independent samples t-test) 
ขั้นตอนการวิเคราะห์ คือ Analyze → Compare Means → Independent  Samples T Test    
 3) การวิเคราะห์ความเที่ยงของเครื่องมือการวิจัยด้วยวิธีการหาค่าสัมประสิทธิ์แอลฟาของครอนบาค 
ขั้นตอนในการวิเคราะห์ คือ Analyze → Reliability (บางเวอร์ช่ันอาจใช้คำสั่ง Analyze → Scale → Reliability)   
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